Kalenderwoche in Excel berechnen

Berechnung

  A B
1 Datum 16.09.2008
2 Kalenderwoche 38

Zu einem Datum soll die Kalenderwoche berechnet werden. In obigem Beispiel steht das Datum in Zelle B1. Die in Zelle B2 Formel für die korrekte Berechnung der Kalenderwoche nach DIN-Norm lautet:

=WENN(B1="";"";KÜRZEN((B1-WOCHENTAG(B1;2)-DATUM(JAHR(B1+4-WOCHENTAG(B1;2));1;-10))/7))

bzw. etwas kürzer

=KÜRZEN((B1-DATUM(JAHR(B1+3-REST(B1-2;7));1;REST(B1-2;7)-9))/7)

Befindet sich das Datum in einer anderen Zelle als B1, muss die Angabe "B1" in der Formel entsprechend angepasst werden. Steht das Datum z.B. in C7, muss B1 durch C7 ersetzt werden. In welcher Zelle die Formel steht ist irrelevant.

Es gibt nur eine einzige Bedingung: das Datum muss > 31.12.1900 sein.

Hintergrundinformation

Für Excel gibt es ein Add-In "Analysefunktionen", das in das Programm eingebunden werden kann. Dieses Add-In bringt die Funktion "Kalenderwoche()" mit, welche jedoch nach amerikanischem Standard die Kalenderwoche ermittelt wonach der 1. Januar immer in Kalenderwoche 1 liegt.

1976 wurde der Wochenbeginn auf Montag festgelegt, vorher gab's die Kalenderwoche in dem Sinne also nicht.

Die erste Woche des Jahres ist definiert als die Woche, in die mindestens 4 Tage fallen (DIN 1355).

Dies entspricht der internationalen Norm ISO 8601 (1988), übernommen von der EU als EN 28601 (1992) und in Deutschland als DIN EN 28601 (1993) umgesetzt.

Beispiel:

  A B C
1 Datum falsch richtig
2 31.12.1999 53 52
3 01.01.2000 1 52
4 02.01.2000 1 52
5 16.09.2000 38 37